Home   About   News   Download   Screenshots   Bugs   
psychotomimetic-constitutional

Express update: 0.3.4 released

Friday, May 7th, 2010 at 23:54

Just a few days after last release, the problem reports start to arrive. The gnome-keyring issues were apparently not solved 100% with the last release. Several different issues were reported from various distros.

This bugfix release will make hang in there and stay usable, even if GnomeKeyring communication fails. I guess it is a situation we’ll have to live with on some distros for a while, untill gnome-keyring-sharp is fixed upstream and rolled out on the distros. Keyring communications with gnome 2.30+ is reported to work on Ubuntu lucid and other distros using the gnome 2.30 compatibilty patch for gnome-keyring-sharp.

Upgrade is strongly recommended.

I want to thank Stefan Ebner and MichaƂ Lisowski for valuable bug reports and testing leading to this release.

Bugs fixed

  • #35: Unhandled exception when trying to use gnome keyring (better fix than in 0.3.3)
  • #37: gnome-keyring problem (crash)
  • #38: Can’t build without gnome-keyring
  • Revert correctly to previous dir on failed local dir change
  • Fixed possible problem when swithing keyring mode with no password file present

You can download 0.3.4 source from the download area. Packages for the various distros will follow.

You may also read the release notes for the related release 0.3.3 and 0.3.2.

Comments:
  1. Stefan Wilkens says:

    Congratulations on your latest release! and thank you for bringing the update to my attention. The Arch Linux AUR entry was updated and tested.

  2. Zoran says:

    love this program!! thank you very much!! Its a bit flaky on opensuse but none the less great!

Leave a Reply

 

Entries (RSS) and Comments (RSS).